tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Johnson <just...@irisusainc.com>
Subject RE: Deploying to ROOT problem
Date Thu, 26 Feb 2004 16:18:04 GMT
I just did the same thing, though with more success.  In build.xml, I set
app.path to "/", and app.name to "ROOT", then adjusted the deploy task to
your first try.  On deployment, ROOT.war is copied to [tomcat]/webapps and
expanded into ROOT (I changed the target depends to "dist" from "compile").
Everything's there, and it browses normally.

However, now the manager app doesn't work, instead simply showing the
directory listing for server/webapps/manager.  Admin still works correctly.
Any idea?

Justin

-----Original Message-----
From: Andrew Watters [mailto:andrew@gointernet.co.uk] 
Sent: Thursday, February 26, 2004 7:03 AM
To: Tomcat Users List
Subject: Deploying to ROOT problem


I'm using the deployer via an ant task to deploy my application. I am 
using deployer 5.0.18 on windows and deploying to tomcat 5.0.18 on both 
windows and linux.  The following works fine

    <deploy url="${server.url}/manager"
            username="${deployer.username}"
            password="${deployer.password}"
            path="/${web.app}"
            war="${dist}/${web.app}.war"
            update="true" />

I also need to deploy to root. I have tried both

    <deploy url="${server.url}/manager"
            username="${deployer.username}"
            password="${deployer.password}"
            path="/"
            war="${dist}/${web.app}.war"
            update="true" />

and

    <deploy url="${server.url}/manager"
            username="${deployer.username}"
            password="${deployer.password}"
            path="/ROOT"
            war="${dist}/${web.app}.war"
            update="true" />

The first option completes successfully but I can see no evidence of my 
application being unpacked; browsing to '/' doesn't show my application. 
The second option also completes successfully and this time I see the 
application unpacked under webapps/ROOT; browsing to '/' doesn't help 
but browsing to '/ROOT/' shows that my appplication is there.

Does anybody know how to deploy to root using the deployer please? Any 
help or advice would be greatly appreciated.

Andrew

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message