tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bodycombe, Andrew" <andrew.bodyco...@siemens.com>
Subject RE: need help adding classpath to Tomcat 5.0.18 NT Service
Date Fri, 06 Feb 2004 16:59:43 GMT
If you moved engine.jar from the shared/lib folder to the common/lib folder,
would that remove the need to explicitly set the classpath?

-----Original Message-----
From: Robert Ensinger [mailto:robert.ensinger@resolutionebs.com] 
Sent: 06 February 2004 16:49
To: 'Tomcat Users List'
Subject: RE: need help adding classpath to Tomcat 5.0.18 NT Service


Hi folks.

I'm still unsuccessful at adding an explicit classpath to Tomcat when
running as a service via the -Djava.class.path= switch detailed below.

Can someone confirm or deny that this is the proper way to add an explicit
classpath to the service? If so, I'll log the bug.

Thanks,
-R

-----Original Message-----
From: Robert Ensinger [mailto:robert.ensinger@resolutionebs.com] 
Sent: Tuesday, February 03, 2004 11:40 PM
To: tomcat-user@jakarta.apache.org
Subject: need help adding classpath to Tomcat 5.0.18 NT Service

Hi Folks,

            I'm working with an app that needs a classpath "kickstart" to
run properly. The jar is deployed to %CATALINA_HOME%\shared\lib\.

 

When starting the server via the startup.bat, the app works properly when
the set classpath variable in the setclasspath.bat is defined as:

set
CLASSPATH=%JAVA_HOME%\lib\tools.jar;%CATALINA_HOME%\shared\lib\engine.jar

 

Now I wish to see this app run when Tomcat is started as a service.

 

Under Java VM in the configuration utility I have added:

-Djava.class.path="%JAVA_HOME%\lib\tools.jar;%CATALINA_HOME%\shared\lib\engi
ne.jar"

 

My Java Options box reads as follows:

-Dcatalina.home="C:\Program Files\Apache Software Foundation\Tomcat 5.0"

-Djava.endorsed.dirs="C:\Program Files\Apache Software Foundation\Tomcat
5.0\common\endorsed"

-Djava.class.path="%JAVA_HOME%\lib\tools.jar;%CATALINA_HOME%\shared\lib\engi
ne.jar"

-Xrs 

 

This isn't working.

I've read the docs and How Tos, spelunked this list, googled, added this
classpath to the systems environmental variables, to the catalina.xml, and
even the catalina.proprties. None of this seems to work.

 

Where is the proper spot to add a classpath to Tomcat running as a service?
What is the proper syntax? (examples?)

 

My java version is 1.4.2. I have successfully setup this app in JRun4 &
Weblogic 8.1 running as services. Need a little help with the Tomcat.

 

Thanks!

 

Robert Ensinger



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message