tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Funk <funk...@joedog.org>
Subject Re: Slow Java app on Tomcat with a 667 MHz CPU
Date Thu, 05 Feb 2004 20:29:54 GMT
Before getting a new CPU - check and see what the CPU is doing. Is the 
bottleneck in IIS, tomcat, or antivirus software checking all filesystem access?

-Tim

Matt Raible wrote:

> I have developed a webapp that uses basic open source stuff (struts,
> hibernate, etc.).  I've been developing/testing it on the following
> platforms - where it works fine and runs lickedy-split:
> 
> OS X 10.3, 1.33 GHz, 1 GB RAM
> Windows XP, 2.6 GHz, 1.5 GB RAM
> Windows 2000 Server, 1 GHz, 512 MB RAM
> Windows 2000 Server, 1.5 GHz, 256 MB RAM
> 
> All of these are running Tomcat 4.1.29 or 4.1.12.  I recently tried to
> deploy it to the "test web server" at my client and it runs dreadfully
> slow.  It takes almost 30 seconds to load a page.  The main difference
> is that the test web server has a 667 MHz CPU.  It has 512 MB RAM, and
> we upgraded it to 1 GB, but that didn't help at all.  
> 
> I've recommended we get a faster CPU for the test web server, but I
> wanted to confirm that this could be the source of the problem.  On this
> server, and the 1.5 GHz/256 MB RAM machine, IIS is integrated with
> Tomcat.  All machines are running JDK 1.4.0 or above.
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message