tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From a a <user10982...@yahoo.com.hk>
Subject Urgent ! Pls help !
Date Sun, 01 Feb 2004 18:58:06 GMT
Dear all,

  I have some problem when connecting apache to tomcat.
  I have installed both apache1.3 and tomcat4.
  I use mod_jk to do the connection. However some problems exists.
  Here is the log file of "mod_jk.log" when I run "apachectl restart":

[Wed Jan 28 20:32:57 2004]  [jk_connect.c (233)]: jk_open_socket, 
connect() failed errno = 111
[Wed Jan 28 20:32:57 2004]  [jk_ajp_common.c (757)]: Error connecting 
to tomcat. Tomcat is probably not started or is listenning on the wrong 
port. Failed errno = 111

and here is the worker.properties:
workers.tomcat_home=/usr/local/jboss-3.0.0_tomcat-4.0.3/catalina
workers.java_home=$(JAVA_HOME)
workers.th=$(workers.tomcat_home)
ps=\
worker.list=ajp13, ajp14
worker.ajp13.port=8009
worker.ajp13.host=localhost
worker.ajp13.type=ajp13
worker.ajp13.lbfactor=1
worker.ajp14.port=8010
worker.ajp14.host=localhost
worker.ajp14.type=ajp14
worker.ajp14.secretkey=secret
worker.ajp14.credentials=myveryrandomentropy
worker.ajp14.lbfactor=1
worker.loadbalancer.type=lb
worker.loadbalancer.balanced_workers=ajp13
worker.inprocess.type=jni
worker.inprocess.class_path=$(workers.tomcat_home)$(ps)lib$(ps)tomcat.jar
worker.inprocess.cmd_line=start
worker.inprocess.jvm_lib=$(workers.th)$(ps)jre$(ps)bin$(ps)classic$(ps)jvm.dll
worker.inprocess.stdout=$(workers.th)$(ps)logs$(ps)inprocess.stdout
worker.inprocess.stderr=$(workers.th)$(ps)logs$(ps)inprocess.stderr


  I don't know what the problem is. Could anyone please help me to 
solve the problem.

Regards,
John LEE




必殺技、飲歌、小星星...
浪漫鈴聲  情心連繫
http://ringtone.yahoo.com.hk/

Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message