tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anupama" <anupa...@aftek.com>
Subject SSL on Tomcat
Date Tue, 24 Feb 2004 04:34:51 GMT
Hi,
     I have referred to 2 links
 1. http://www.verisign.com/support/csr/tomcat/v00.html
 2 http://java.sun.com/webservices/docs/1.1/tutorial/doc/WebAppSecurity5.html
      According to first one I imported a chain certificate   (http://www.verisign.com/support/install/intermediate.html)
  and the new
certificate(received in the mail) in the keystore and the installed Test CA Root (http://www.verisign.com/server/trial/faq/index.html)
in the
browser.
      The Test CA Root has been successfully been installed in the browser .On the server
end the the logs show a client hello but Server hello does
      not follow. 

     I am facing problems with SSL using the Test certificate.
>   I am using Tomcat 4.0 and platform is Windows.
>   The version of jsse is 1.0.3 and using jdk1.3 and jre version is 1.3.1
>   My classpath contains the 3 jars of the JSSE and the java.security  file
> contains the
>   security.provider.2=com.sun.net.ssl.internal.ssl.Provider
>
>    I have installed the CA Test root in the browser and imported the
> intermediate and  mailed certificates in the certificate file of java
> %JAVA_HOME%\jre\lib\security\cacerts.
>    And enabled my tomcat configuration SSL settings
>
>    This is the dump i get on tomcat when i set the debugging on
>    *** ClientHello, v3.1
> RandomCookie:  GMT: 0 bytes = { 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 249,
72,
> 245
> , 52, 87, 103, 49, 73, 141, 121, 46, 180, 203, 187, 39, 235 }
> Session ID:  {}
> Cipher Suites:  { 0, 4, 0, 5, 0, 10, 0, 9, 0, 100, 0, 98, 0, 3, 0, 6, 0,
19,
> 0,
> 18, 0, 99 }
> Compression Methods:  { 0 }
> ***
> %% Created:  [Session-2, SSL_NULL_WITH_NULL_NULL]
> HttpProcessor[8443][4], SEND SSL v3.1 ALERT:  fatal, description =
> handshake_failure
> HttpProcessor[8443][4], WRITE:  SSL v3.1 Alert, length = 2
> HttpProcessor[8443][4], SEND SSL v3.1 ALERT:  warning, description =
> close_notify
> HttpProcessor[8443][4], WRITE:  SSL v3.1 Alert, length = 2
> As per the SSL  specifications the client hello should be followed by a
> server hello.
> What could be the problem.? Could u please help out
>
>
>



  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message