tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Witucki" <CWITU...@independenthealth.com>
Subject Re: Memory climbs until I get an OutOfMemory Error
Date Mon, 26 Jan 2004 13:19:38 GMT
Matt, 
We are experiencing the same issue.  It doesn't appear that there is a clear answer, just
lots of guessing.  We have contacted Novell because we are using their Portal services.  We
have upgraded Tomcat, change parameters in the web.xml, and servlet.properties files and no
luck.  We are using a Windows 2000 to run Tomcat.  Please forward me anything you get that
could resolve this.

Christian Witucki
Network Analyst
375 Essjay Road
Williamsville, NY 14221
716-631-3001 x3812

CONFIDENTIALITY NOTICE. This e-mail and attachments, if any, may contain confidential information
which is privileged and protected from disclosure by Federal and State confidentiality laws,
rules or regulations.  This e-mail and attachments, if any, are intended for the designated
addressee only .  If you are not the designated addressee, you are hereby notified that any
disclosure, copying, or distribution of this e-mail and its attachments, if any, may be unlawful
and may subject you to legal consequences.  If you have received this e-mail and attachments
in error, please contact Independent Health immediately at (716) 631-3001 and delete the e-mail
and its attachments from your computer.  Thank you for your attention.

>>> matt@raibledesigns.com 01/24/04 03:10PM >>>
I have a weird issue on a server.  The server is a Windows 2000 Server
with IIS installed and Tomcat 4.1.12.  It uses the isapi connector to
proxy requests from IIS to Tomcat.  Everything has been working fine
with this setup for several months.  Last week, I tried to add a new
application to the Tomcat instance.  This application is a bit more than
the existing app - it has a JDBCRealm and connection pool setup.  

Here's the strange behavior.  After starting Tomcat, the memory used
climbs to about 48MB, but when I hit the first page in the new app - the
memory usage by "java.exe" starts climbing off the charts.  It increases
by about 1 MB every second and before long it reaches the threshold
(256MB) and it throws an out of memory error - and it's just on the
welcome page!  

The only thing I've changed since dropping my app in tomcat is to use
tomcat's authentication, rather than passing it through from IIS.  Has
anyone else seen this behavior?

Thanks,

Matt


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org 
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org 



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message