tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Tulley" <JTUL...@novell.com>
Subject RE: white pages in tomcat 4.1.24
Date Wed, 14 Jan 2004 19:22:59 GMT
I know that there is the possibility of JSPs being returned as a blank
page, if it was unable to create a session.  I have only seen this in
doing high-load (like typically unrealistically high) testing.  Maybe
you are hitting that.

Of course, that wouldn't match the behavior you are seeing of being
able to access non-existing pages.

It is something to check though.

>>> Thomas.Rimmele@swissinfo.ch 01/14/04 01:54PM >>>
Well, unfortunately their is no additional information. The webapp 
just delivers white pages. 
No log entry. normally our servlets logs every hit, but not after the
crash.
You can access any page you like also noexistent ones and there is no
error 
message, just a white page. 
We have this problem just on the machine with 24 webapps. And the
problem 
appeared first after we have installed 4 or 5 new webapps. Other
machines
with 
similar load and size, but less webapps never had this problem. All
our
webapps run absolutely 
the same code. We don't have unshared classes or libs. 
When we used mod_webapp and an application crashed, the same webapp
was
still 
accessible via http connector. It is not like that anymore since we
use
mod_jk2.

-Thomas



-----Original Message-----
From: Shapira, Yoav [mailto:Yoav.Shapira@mpi.com] 
Sent: Mittwoch, 14. Januar 2004 14:45
To: Tomcat Users List
Subject: RE: white pages in tomcat 4.1.24



Howdy,
A webapp crashes.  Has anyone experienced the same?  Sure.  What was
the
solution?  Depends on why it crashed.

You will need to provide more information in order to get more help,
starting with the content of the tomcat logs when your webapp crashes
;)

Yoav Shapira
Millennium ChemInformatics


>-----Original Message-----
>From: Thomas.Rimmele@swissinfo.ch [mailto:Thomas.Rimmele@swissinfo.ch]

>Sent: Wednesday, January 14, 2004 7:36 AM
>To: tomcat-user@jakarta.apache.org 
>Subject: white pages in tomcat 4.1.24
>
>Hello,
>
>we are using tomcat 4.1.24 apache 1.3.29 and the most recent mod_jk2
on
>solaris 8.
>There are 24 webapps running. From time to time a webapp crashes
>and delivers just no-content-pages from then on. All other webapps
>continue running correctly.
>
>Does anyone have experienced the same? What was the solution?
>
>We had the same problem before when we used mod_webapp. Since
>mod_webapp is deprecated, we moved to mod_jk2 instead of
>posting the problem in the mail list. But it was not the solution.
>
>Thanks, Thomas


Jeff Tulley  (jtulley@novell.com)
(801)861-5322
Novell, Inc., The Leading Provider of Net Business Solutions
http://www.novell.com

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message