tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mohammad Musleh" <mmos...@mum.edu>
Subject RE: MM:Tomcat with SSL
Date Tue, 13 Jan 2004 16:40:13 GMT
Hi;

I'm using J2SDK 1.4.2 that comes with JSSE, I don't need to install JSSE as
a separate component. I checked the java.security file and I found all
providers are there, this is what I have in that file

security.provider.1=sun.security.provider.Sun
security.provider.2=com.sun.net.ssl.internal.ssl.Provider
security.provider.3=com.sun.rsajca.Provider
security.provider.4=com.sun.crypto.provider.SunJCE
security.provider.5=sun.security.jgss.SunProvider

Thanks

Mohammad Musleh
Software Architect and Developer
Computer Science Dept., MUM
Fairfield, IA 52557 USA
Phone: (641) 472 7000 x 4326


-----Original Message-----
From: Altankov Peter [mailto:PAltankov@globul.bg]
Sent: Tuesday, January 13, 2004 10:35 AM
To: Tomcat Users List
Subject: RE: MM:Tomcat with SSL


I think this has the taste of wrong/not_provided security provider.
If you are using sun's JSSE

Add this to your $JAVA_HOME/jre/lib/security/java.security

security.provider.1=sun.security.provider.Sun
security.provider.2=com.sun.net.ssl.internal.ssl.Provider
security.provider.3=com.sun.rsajca.Provider



> -----Original Message-----
> From: Keshav Sarin [mailto:KSarin@net-deposit.com]
> Sent: 13 Януари 2004 г. 18:08
> To: tomcat-user@jakarta.apache.org
> Subject: Re: MM:Tomcat with SSL
>
>
> Look for a .keystore file under the home directory of the
> user that generated the key. Make sure Tomcat is started by
> the same user.
>
> >>> mmosleh@mum.edu 01/13/04 09:01AM >>>
> GlacierDear guys;
>
> - I have Java 2 SDK 1.4.2 that come with JSSE
> - Apache Tomcat version 4.1
> - I'm using Windows environment
>
> I'm having a problem when I configured Tomcat with SSL, I
> followed HOW TO steps in Apache web site like this
>
> 1. have generated the key using this command
> %JAVA_HOME%\bin\keytool -genkey -alias tomcat -keyalg RSA
>
> 2. Uncommented the "SSL HTTP/1.1 Connector" in server.xml
>
> 3. Restarted Tomcat
>
> But I got the following problem
> Jan 13, 2004 9:56:44 AM org.apache.coyote.http11.Http11Protocol init
> SEVERE: Error initializing socket factory
> java.lang.ClassNotFoundException: Can't find any SSL
> implementation at
> org.apache.tomcat.util.net.SSLImplementation.getInstance(SSLIm
> plementation.j
> ava:97)
> at
> org.apache.tomcat.util.net.SSLImplementation.getInstance(SSLIm
> plementation.j
> ava:103)
> ....
>
> I searched for SSLImplementation class and I found it in a
> jar file, and that jar file is in the class path.
>
> Any answers or suggestion why I'm getting this error and how
> to solve it???
>
>
> Thanks
> Mohammad Musleh
> Software Architect and Developer
> Computer Science Dept, MUM
> Fairfield, IA 52557 USA
> Phone: (641) 472 7000 x 4326

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message