tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Li <tawe...@yahoo.com>
Subject Re: Acrobat 6.0.1 plug-in for IE and Tomcat 4.1.x problem
Date Tue, 27 Jan 2004 17:18:29 GMT
The code here fixed the Coyote Response object but the real problem 
seems to be in the Catalina BaseResponse object which the charset is 
appended.

David

On Jan 26, 2004, at 9:39 PM, Tim Funk wrote:

> Its a fixed bug.
>
> http://nagoya.apache.org/bugzilla/show_bug.cgi?id=24970
>
> -Tim
>
> David Li wrote:
>
>> Hi,
>>   I don't subscribe to the list so direct reply to taweili@yahoo.com 
>> would be greatly appreciated.
>>   We recently detect a problem with sending generated PDF to Acrobat 
>> 6.0.1's IE plug-in. In Tomcat, if the ContentType is set, a charset 
>> is automatically appended to it. This causes problem with Acrobat 
>> 6.0.1's IE plug-in. So far, we have summarize the following 
>> conditions:
>> 1. ContentType: application/pdf
>> This works fine.
>> 2. ContentType: application/pdf;
>> This shows blank pages
>> 3. ContentType: application/pdf;charset=UTF-8
>> This shows error message of corrupted PDF file. However, if we 
>> download it, it can be open correctly with Arcobat 6.0.1. Only 
>> plug-in complaining the problem.
>>   I have tried to contact Adobe about this but, of course, get no 
>> response. I think this is more of a problem of Adobe's plug-in 
>> implementation rather then Tomcat's problem. I have check the source 
>> codes, there is no way to disable appending charset if setContentType 
>> is called.
>>   Any suggestion is appreciated.
>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message