tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Januski, Ken" <kjanu...@phillynews.com>
Subject RE: OT?:Can't include .js file on jsp page controlled by front co ntro ller servlet
Date Mon, 12 Jan 2004 17:24:37 GMT
Thanks,

The .js file is a downloaded calendar, i.e. I didn't write it myself. I'm
including it, per the instructions that came with it, using src="http:/...".
I believe I've tried including it using a system file path and still had
problems. But I'll give it another try just to make sure.

I guess I should have added that I'm also a beginner with javascript and
that might be part of the problem.

Ken

-----Original Message-----
From: pete.storey@kisstechnologies.co.uk
[mailto:pete.storey@kisstechnologies.co.uk]
Sent: Monday, January 12, 2004 12:07 PM
To: Tomcat Users List
Subject: Re: OT?:Can't include .js file on jsp page controlled by front
contro ller servlet


A JavaScript include is a purely HTML thing - it shouldnt be processed in 
any way by the server.  You can do it by going:

<script language="JavaScript" src="xyz.js"></script>

cheers
Pete

Kiss Technologies

http://www.kisstechnologies.co.uk/

4, Percy Street
London
W1T 1DF

Phone numbers:

Phone 020 7692 9922
Fax 020 7692 9923




"Januski, Ken" <kjanuski@phillynews.com>
12/01/2004 16:58
Please respond to "Tomcat Users List"
 
        To:     Tomcat Users List <tomcat-user@jakarta.apache.org>
        cc: 
        Subject:        OT?:Can't include .js file on jsp page controlled 
by front contro ller servlet


I may be getting in over my head here as I'm really not all that familiar
with patterns. And I'm not sure that the pattern has anything to do with
problem. But I have a controller servlet through which all web requests 
must
pass. It has worked fine as is. Until I tried to include a .js file on a 
jsp
page. In that case it seems to either print it out to page, rather than
execute it, or it tries to use requestDispatcher portion of controller
servlet to forward/include it. Normally the requestDispatcher forwards
request to the requested page after it checks to see if user is logged in.
But now it seems to go into an infinite loop when forwarding. And  I guess
it's trying to use requestDispather.include because the .js resource is
included via a "src='http:...' " request. I know that this is a very vague
question but I wonder if anyone has any clues as to where the problem 
might
lie or what I can start experimenting with.

email protected and scanned by AdvascanTM - keeping email useful - 
www.advascan.com




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message