tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brennon Obst" <bren...@ienergyglobal.com>
Subject RE: virtual hosting and tomcat wt Apache 2 and JK2
Date Mon, 19 Jan 2004 23:54:20 GMT
Thank you Charlie, I missed this email in my last response. I will
follow that tutorial and report back.

Cheers mate!

/Brennon

-----Original Message-----
From: Cox, Charlie [mailto:ccox@cincom.com] 
Sent: Tuesday, 20 January 2004 3:30 AM
To: 'Tomcat Users List'
Subject: RE: virtual hosting and tomcat wt Apache 2 and JK2 


You probably have this bug(different than the other one posted)
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22045

The only solution I have found is to map each virtualhost/dir in your
workers2.properties that should go to tomcat. While a PITA(at least for
me), it does work.

See this link for an example.
http://www.aexx.net/arcane/article.jsp?article=tomcat4-apache2-jk2

These are the only 2 things that I have found about this issue. Charlie 

> -----Original Message-----
> From: Brennon Obst [mailto:brennon@ienergyglobal.com]
> Sent: Monday, January 19, 2004 1:02 AM
> To: 'Tomcat Users List'
> Subject: RE: virtual hosting and tomcat wt Apache 2 and JK2
> 
> Thank you Martina,
> 
> I will check my version and report back =/
> 
> /Brennon
> 
> -----Original Message-----
> From: Frankl Martina [mailto:martina.frankl@siemens.com]
> Sent: Friday, 16 January 2004 10:23 PM
> To: Brennon Obst; 'Tomcat Users List'
> Subject: AW: virtual hosting and tomcat wt Apache 2 and JK2
> 
> 
> Maybe your jk2 version still has this bug: 
> http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18472
> 
> hth
> Martina
> 
> 
> > -----Urspr√ľngliche Nachricht-----
> > Von: Brennon Obst [mailto:brennon@ienergyglobal.com]
> > Gesendet: Freitag, 16. Januar 2004 05:43
> > An: 'Tomcat Users List'
> > Betreff: virtual hosting and tomcat wt Apache 2 and JK2
> >
> >
> >
> > Dear usergroup,
> >
> > When I activated the following in my Apache 2 config within the 
> > VirtualHost block for xxxxx.xxx.net: <Location "/">
> >
> > JkUriSet worker ajp13:localhost:8009
> >
> > </Location>
> >
> > ALL of my virtual hosts stopped working and started complaining of 
> > not being able to find /index.jsp
> >
> > It is like the <Location "/"> wasn't confined to the VirtualHost but

> > rather became a server wide configuration.
> >
> > When I activated the apache<-->tomcat connection it took over ALL of

> > the virtual hosts and was routing them through Tomcat, does
> > anyone know how to
> > stop that?
> >
> > Is it my Apache 2 and JK2 connectors, where do I turn now? Thank you

> > in advance,
> >
> > Brennon Obst
> >
> >
> > Java Security Programmer
> > iEnergy Main Branch
> > 39 Melbourne St. / Brisbane
> > p. (617) 3846-6666
> > brennon@ienergyglobal.com
> >
> >
> >
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message