tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shapira, Yoav" <Yoav.Shap...@mpi.com>
Subject RE: jaas.jar not included w/ Tomcat 5.0.16 - why?
Date Thu, 15 Jan 2004 14:37:53 GMT

Howdy,

>jaas.jar is no longer present in server/lib/ as it was in Tomcat 4.x.

Small correction there: it was in server/lib for tomcat 4.1.x, not
4.0.x.

>this causes ClassNotFoundExceptions when running under JDK 1.3. was
this
>an oversight or was it intentional. if it was intentional, it should be
>documented in RUNNING.txt.

I doubt it was an oversight, as it takes some effort to drop a jar from
our distribution.  But I don't see much documentation for it.  And I
know the JAAS Realm and associated JAASMemoryLoginModule are still
present in the distribution.  I also know tomcat has been built on JDK
1.4 for a while now, so the absence of the jaas.jar would necessarily by
detected.  I'll investigate a bit more.  Thanks for bringing this up.
All you had to do is place jaas.jar in server/lib (or the jre/ext
directory I assume) ?

Yoav Shapira



This e-mail, including any attachments, is a confidential business communication, and may
contain information that is confidential, proprietary and/or privileged.  This e-mail is intended
only for the individual(s) to whom it is addressed, and may not be saved, copied, printed,
disclosed or used by anyone else.  If you are not the(an) intended recipient, please immediately
delete this e-mail from your computer system and notify the sender.  Thank you.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message