tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From OpusB...@netscape.net
Subject Jetspeed 1.0 with Tomcat 5.0
Date Mon, 26 Jan 2004 18:45:51 GMT
Hi,

I have been using Jetspeed with Tomcat 4.1.24 with great success.  I upgraded to Tomcat 5.0.18
and it has broken my JAAS authentication.  Initially it could not find my classes which I
fixed by the diretory that they live in to the catalina.properties.  But now I am getting:

javax.security.auth.login.LoginException: org.apache.turbine.services.InstantiationException:
ServiceBroker: unknown service PortalAuthentication requested

I have tried putting my configuration files under %CATALINA_ROOT%/conf but no luck.  Has anyone
else tried this.

My JAAS configuration file looks like:

MyAppServletContainer
{
    com.myapp.security.ServletContainerLoginModule required;
};

MyAppWebServices
{
    com.myapp.security.MyAppLoginModule required expiration-period="0" cache="false";
};

MyAppWeb
{
    com.myapp.security.MyAppLoginModule required expiration-period="0" cache="false";
};

Any ideas?

__________________________________________________________________
New! Unlimited Netscape Internet Service.
Only $9.95 a month -- Sign up today at http://isp.netscape.com/register
Act now to get a personalized email address!

Netscape. Just the Net You Need.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message