tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Schmitt <d...@shiftomat.de>
Subject Re: Problems with jk2 on IIS 5.0 and Tomcat 4.0
Date Mon, 19 Jan 2004 19:36:10 GMT
Rasmus,
I didn't manage to get the T4.0 jk2.02 IIS5 combi to work either.
It worked for me with an older jk2.01 bin.
Another user at this forum suggested to use a jk2.shm file with size 
power of 2.
If you have the possibility to upgrade to Tomcat 4.1.29 you can try our 
jk2 installer at http://www.shiftomat.com/opensource , but you have to 
remove your manual setup before.

hope this helps

Rasmus Munk wrote:

> Tried it, but it still does not work. Mostly the requests is passed to
> tomcat correctly. The log then look like this:
> 
> [Mon Jan 19 14:33:20 2004] (debug ) [jk_isapi_plugin.c (288)]
> [Mon Jan 19 15:28:34 2004] (debug ) [jk_service_iis.c (93)]  Into
..
> jk_ws_service_t::write
> [Mon Jan 19 15:28:34 2004] (debug ) [jk_isapi_plugin.c (515)]
> HttpExtensionProc service() returned OK
> 
> It seems like an error occurs: Error sending initial post -1 0 0. Does
> anyone know what this means?
> 
> Even though the log says: HttpExtensionProc service() returned OK, a
> response is never returned. The browser simply gets a timeout!
> 
> Any help would be greatly appreciated
> 
> Thanks,
> 
> Rasmus
> 
> -----Original Message-----
> From: Jeff Trout [mailto:jeff.trout@corp.terralycos.com] 
> Sent: 19. januar 2004 13:39
> To: Rasmus Munk
> Cc: tomcat-user@jakarta.apache.org
> Subject: Re: Problems with jk2 on IIS 5.0 and Tomcat 4.0
> 
> On Fri, 16 Jan 2004 15:54:00 EST
> "Rasmus Munk" <munk@writeme.com> wrote:
> 
> 
>>HttpFilterProc [/camping_lars/servlet/camping.XMLServer.Server] is a 
>>servlet url - should redirect to ajp13:localhost:8009 HttpFilterProc 
>>check if [/camping_lars/servlet/camping.XMLServer.Server] is pointing 
>>to the web-inf directory HttpFilterProc started In HttpFilterProc 
>>Virtual Host redirection of localhost : 80 HttpFilterProc 
>>[/jakarta/isapi_redirector2.dll] is not a servlet url HttpFilterProc 
>>check if [/jakarta/isapi_redirector2.dll] is pointing to the web-inf 
>>directory HttpExtensionProc started HttpExtensionProc could not get a 
>>worker for name HttpExtensionProc worker is NULL
>>
> 
> 
> I just recently spent a few days struggling with this
> 
> 1. Did you setup the /jakarta/ virtual dir properly (pointing it to the dir
> that has isapi_redirector2.dll?
> 
> 2. Did you install isapi_redirector2.dll at the server or site level?
> I found on w2k sp4 that I had to install it at the SITE level... Oddly it
> worked fine at the server level on sp2.  If I get some time I'll investigate
> more.
> 
> Good luck!
> 
> 
> --
> Jeff Trout <jeff.trout@corp.terralycos.com> Global Engineering / Terra Lycos
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 


-- 
Daniel Schmitt

shiftomat Chat Systems
http://www.shiftomat.de

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message