tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Hardy <ahardy.str...@cyberspaceroad.com>
Subject caching nightmare
Date Fri, 16 Jan 2004 10:04:29 GMT
Maybe I'm just an idiot, but I'm having a nightmare with the caching in 
my webapp. I asked a colleague to look at it and he's baffled too.

It's probably something to do with the resource bundles. I had 
everything in an English and also a German .properties file, for testing 
purposes, but then decided to ditch the German version until it's 
completely finished.

Even though I deleted the German .properties file, shutdown tomcat, 
deleted the whole webapp and redeployed and deleted the cache in 
$CATALINA_HOME/work/.... , the German strings are still being cached 
somewhere.

I have run a grep on the German string to find it in any file in the 
whole of the tomcat install directory, but haven't found it.

In the HTTP headers, I have set pragma=no-cache, cache-control=no-cache 
& expires=Thu, 01 Jan 1970 00:00:00 GMT

I have cleared the cache from my browser and done refreshes a thousand 
times. Could it be cached anywhere else on my machine between tomcat and 
the browser?

Adam
-- 
struts 1.1 + tomcat 5.0.16 + java 1.4.2
Linux 2.4.20 Debian


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message