tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Funk <funk...@joedog.org>
Subject Re: Tomcat 4.1.29 versus Tomcat 5
Date Tue, 13 Jan 2004 11:57:30 GMT
Going from 4.1 to 5 should be easier than going from 4.0 to anything.

If all your webapps are container agnostic - the upgrade should be pretty easy.

If you have custom realms, valves, they might need some re-write. (But it 
really depends on what you did. Some Valve, Realm code is still identical in 
4.1 and 5)



-Tim


Daniel Gibby wrote:
> Great, I'm sold! OK, so what are the biggest problems there have been in 
> upgrading?
> What do you mean an app running on 4.x may not work on 5.0.x? Is this 
> only because of changes in the JSP spec, and older 1.2 is not compatible 
> with the 2.0 spec?
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message