tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Federico" <li...@lodoss.net>
Subject Apache 1.3.29 + mod_jk2 + tomcat 4.1.29: cannot get SSL to work via Apache
Date Mon, 19 Jan 2004 23:50:47 GMT
hi,

  we've at work 2 different 1.3.29 apache daemons to handle regular and ssl
connection, both are working against a single tomcat 4.1.29, using mod_jk2 in
both cases.
  the first daemon works just fine and the connection if forwarded to tomcat's
8009 port as we've configured it.
  we've also the ssl part for tomcat configured and working properly; the
pages are displayed when we direct our browsers to https://ip-address:8443/,
but we cannot get the ssl apache to handle the connection on behalf of
tomcat's 8443 port.
  we're pretty sure it's something related to workers2.properties, but so far
we're unable to find the problem.
  for every request, jk2.log shows:

[Mon Jan 19 23:38:35 2004]  (error) [jk_msg_ajp.c (447)]: msgAjp.receive():
Bad signature 153
[Mon Jan 19 23:38:35 2004]  (error) [jk_channel_socket.c (549)]:
channelSocket.receive(): Bad header
[Mon Jan 19 23:38:35 2004]  (error) [jk_workerEnv.c (482)]:
workerEnv.processCallbacks() Error reading reply
[Mon Jan 19 23:38:35 2004]  (error) [jk_worker_ajp13.c (416)]: ajp13.service()
ajpGetReply recoverable error 21000
[Mon Jan 19 23:38:35 2004]  (error) [jk_msg_ajp.c (447)]: msgAjp.receive():
Bad signature 153
[Mon Jan 19 23:38:35 2004]  (error) [jk_channel_socket.c (549)]:
channelSocket.receive(): Bad header
[Mon Jan 19 23:38:35 2004]  (error) [jk_workerEnv.c (482)]:
workerEnv.processCallbacks() Error reading reply
[Mon Jan 19 23:38:35 2004]  (error) [jk_worker_ajp13.c (416)]: ajp13.service()
ajpGetReply recoverable error 21000
[Mon Jan 19 23:38:35 2004]  (error) [jk_worker_ajp13.c (512)]: ajp13.service()
Error  forwarding ajp13:testbed:8443 1 0
[Mon Jan 19 23:38:35 2004]  (error) [mod_jk2.c (427)]: mod_jk.handler() Error
connecting to tomcat 21000

     my workers2.properties follows:

[channel.socket:testbed:8443]
tomcatId=testbed:8443

[shm:]
file=${serverRoot}/logs/jk2.shm
size=1000000
debug=0
disabled=0   

[uri:/*.jsp]

[uri:domain.net/*]

  as for the httpd.conf, only 'LoadModule jk2_module module/mod_jk2.so' was added.
  we've tried several things, but we're running out of ideas, and the
documentation is not really helpful.
  we'd appreciate any help or documentation references.
  thanks in advance,

  Federico.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message