tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sushma <schakkir_2...@yahoo.com>
Subject Re: adding new jars to classpath
Date Tue, 06 Jan 2004 18:40:27 GMT

I checked the faq and also see the same
java.lang.NoClassDefFoundError: javax/servlet/Filter
Error message. I verified that there is only one
servlet.jar in common/lib.
The new jars that I added in the classpath depend on
servlet.jar. So is the error due to this ? 

-sushma


--- Tim Funk <funkman@joedog.org> wrote:
>
http://jakarta.apache.org/tomcat/faq/classnotfound.html
> 
> Especially read the link for  Tomcat 4.1 Classloader
> HOWTO
> 
> -Tim
> 
> sushma wrote:
> 
> > Hi,
> > 
> > I added new jars to the classpath in
> > setclasspath.sh(using tomcat 4.1.27) but these are
> not
> > being picked up. I got a CNF error. I copied these
> > jars to common/lib and then it worked fine. These
> jars
> > are used by the custom realm classes placed at
> > server/lib.
> > 
> > why am I not able to modify the classpath to add
> new
> > jars ?
> >  
> 
> 
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail:
> tomcat-user-help@jakarta.apache.org
> 


__________________________________
Do you Yahoo!?
Yahoo! Hotjobs: Enter the "Signing Bonus" Sweepstakes
http://hotjobs.sweepstakes.yahoo.com/signingbonus

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message