tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian Warburton" <...@irax.com>
Subject Tomcat 5.0 and php servlet installation problem
Date Tue, 20 Jan 2004 18:28:57 GMT
I think I have nearly got my tomcat5/phpPHP 4.3.4  installation
to work: but I am getting this error when I load a php testpage

CLASSPATH IS SET TO
/usr/java/j2sdk_nb/j2sdk1.4.2/bin/:/usr/java/j2sdk_nb/netbeans3.5.1/tomcat406/common/lib/servlet.jar:/var/tomcat/jakarta-tomcat-5.0.16-src/src/jakarta-tomcat-5/build/server/lib/phpsrvlt.jar

LD_LIBRARY_PATH is
/usr/local/apache/modules/libphp4.so

I think the issue is with java.library.path being incorrect but
don't know where to correct it.

root cause

java.lang.UnsatisfiedLinkError: no php4 in java.library.path
	java.lang.ClassLoader.loadLibrary(ClassLoader.java:1491)
	java.lang.Runtime.loadLibrary0(Runtime.java:788)
	java.lang.System.loadLibrary(System.java:834)
	net.php.reflect.loadLibrary(reflect.java:34)
	net.php.reflect.(reflect.java:29)
	net.php.servlet.init(servlet.java:157)
	org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:509)
	org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:164)
	org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:211)
	org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:805)
	org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:696)
	org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:605)
	org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:677)
	java.lang.Thread.run(Thread.java:534)




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message