tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dima Gutzeit" <d...@mailvision.net>
Subject JSPC under Tomcat5.0.18
Date Sun, 26 Jan 2003 09:46:13 GMT
Dear list members ,

Recently I've decided to redeploy some of my projects with Tomcat5.0.18.

Part of my projects are precomplied JSP files which were compiled using JSPC that came with
Tomcat4.1.29.
To my surprise those classes were not able to run properly with Tomcat5, while deploying JSP
files without precompiling worked alright.

The next step was to recompile JSP files allover using JSPC shipped with Tomcat5 and so I
did using the Latest ANT release 1.6.0.
ANT failed to complie the files with the following reason : 

Buildfile: build.xml

jspc:
     [jspc] Compiling 21 source files/var/tomcat5/webapps/System/src/jsp/org/apache/jsp
  [jasperc] error:org.apache.jasper.JasperException: Unrecognized option: -v9.  Use -help
for help.
  [jasperc]     at org.apache.jasper.JspC.setArgs(JspC.java:307)
  [jasperc]     at org.apache.jasper.JspC.main(JspC.java:231)


Can anyone tell me what is the issue here ? Why it is not backwards compatible ? How can I
precompile the JSP files for Tomcat 5 ?

Thanks in advance.



Regards , 
Dima Gutzeit.
---------------------------------
MailVision LTD. 
R&D Team. 
Phone: 972-4-8500505 ext. 14 
Fax: 972 - 4 - 8508000 
http://www.mailvision.com 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message