tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allan Bruce" <alla...@f2s.com>
Subject Re: Linking tomcat with apache
Date Mon, 19 Jan 2004 14:51:46 GMT
Thanks Tim,

I am a step closer I think, my configs are detailed below.  I have tomcat
running with jk2 fine, the log states

INFO: JK2: ajp13 listening on /0.0.0.0:8019


but apache has the following error:

[Mon Jan 19 14:32:37 2004] [notice] Apache-AdvancedExtranetServer/2.0.44
configured -- resuming normal operations
[Mon Jan 19 14:32:37 2004] [error] shm.init(): No file
[Mon Jan 19 14:33:23 2004] [error] workerEnv.init() create slot epStat.0
failed
[Mon Jan 19 14:33:23 2004] [error] lb.service() worker failed
ajp13:localhost:8019
[Mon Jan 19 14:33:23 2004] [error] lb.service() unrecoverable error...
[Mon Jan 19 14:33:23 2004] [error] mod_jk.handler() Error connecting to
tomcat 120000
[Mon Jan 19 14:34:28 2004] [error] shm.init(): No file
[Mon Jan 19 14:35:53 2004] [error] workerEnv.init() create slot epStat.2
failed
[Mon Jan 19 14:35:53 2004] [error] lb.service() worker failed
ajp13:localhost:8019
[Mon Jan 19 14:35:53 2004] [error] lb.service() unrecoverable error...
[Mon Jan 19 14:35:53 2004] [error] mod_jk.handler() Error connecting to
tomcat 120000




What am I doing wrong?
Thanks
Allan

----config files added/changed
--added to /etc/httpd/conf/commonhttpd.conf
LoadModule jk2_module /usr/lib/apache2/mod_jk2.so

--/etc/httpd/conf/workers2.properties
#min for working
[channel.socket:localhost:8019]
info=Ajp13 forwarding over socket
tomcatId=localhost:8019
# Map the Tomcat examples webapp to the Web server uri space
[uri:/examples/*]
info=Map the whole webapp


--/usr/local/sites/tomcat/tomcat/conf/jk2.properies
# list of needed handlers.
handler.list=apr,channelSocket,request
# Override the default port for the channelSocket
channelSocket.port=8019
# Dynamic library
apr.NativeSo=/usr/lib/apache2/mod_jk2.so


--added to /usr/local/sites/tomcat/tomcat/conf/server.xml
<Connector className="org.apache.coyote.tomcat4.CoyoteConnector" port="8019"
minProcessors="5" maxProcessors="75" enableLookups="true"
redirectPort="8443" acceptCount="10" debug="0" connectionTimeout="0"
useURIValidationHack="false"
protocolHandlerClassName="org.apache.jk.server.JkCoyoteHandler" />



----- Original Message ----- 
From: "Tim Funk" <funkman@joedog.org>
To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
Sent: Sunday, January 18, 2004 7:23 PM
Subject: Re: Linking tomcat with apache


> http://jakarta.apache.org/tomcat/tomcat-4.1-doc/jk2/index.html
> http://nagoya.apache.org/wiki/apachewiki.cgi?Tomcat/Links
>
> -Tim
>
> Allan Bruce wrote:
> > I have tomcat and apache both setup and running.  At the moment, I am
using
> > a permanent redirect for urls to servlets to tomcat.  But this is not
> > correct.  How do I get them set up correctly? I have jk2 installed.
> > Thanks
> > Allan
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message