tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "George Shafik" <gsha...@optusnet.com.au>
Subject Re: MOD_JK2 also Fails aaaggggg@###!!!
Date Fri, 02 Jan 2004 14:05:05 GMT
Yep,

without going into too much detail IT DOESN'T WORK ITS REALLY BROKE.

Over the past 4 weeks I've made 8 REAL attempts, spent around 30 hours of my time and short
of writing the whole thing myself I went with mod_webapp.so, tomcat-warp.jar for Apache 1.3.29
Tomcat 4.1.29. The build is stuffed and its not the version of libtool or anything else something
is broke when you try to build on RH9 exactly what is up to the many lib, builds scripts between
Ant and Make - if I have enough time over the next decade I may be able to solve it however
apache 1.3.29 can talk to Tomcat 4.1.29 for now through webapp connector, 

Now if through some miracle someone out there has managed to REALLY build this on current
vanilla install of RH9 (not enterprise) I want a copy of mod_jk2.so file,  httpd.conf, serer.xml,
copy of the SOURCE jakarta-tomcat -connector used, a README file with exactly what you did
and the best part for last I want a dump of your system output from the build of the mod_jk2.so
in order to make me a believer. Keep in mind I want to build from source no binaries and Apache
2.0.48 connecting to Tomcat 4.1.29 through mod_jk2.so - all built from source just in case
you mist my point. 

Greatest apologies but like many out there I'm very frustrate when stuff that I really don't
want to know much about stops working because of compromises in testing on the various platforms
or the Readme files aren't updated along side the respective release even though this is after
all open source.

Cheers,
George


"Excellence is not an act, but a habit."
- Aristotle -







----- Original Message ----- 
From: "Suneel" <suneel@lifetreeindia.com>
To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
Sent: Friday, January 02, 2004 6:24 PM
Subject: MOD_JK2 also Fails aaaggggg@###!!!


Hi 
    since runing mod_jk is throwing me only jsp source instead of jsp..i am trying mod_jk2.
Now when i start apache i get error ../native2/server/mod_jk2.c is not the correct version.
So i got the source and compiled it using buildconf.sh and configure, but in my native2/server/apache2
there is no mod_jk2.so !!!! my config is rh9,tomcat 4.1.29 & apache 2.0.48. At this point
i want to take a shotgun and blow my comp. What is wrong here?

regards
suneel

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message