tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Januski, Ken" <kjanu...@phillynews.com>
Subject RE: IIS redirector works first time then fails
Date Wed, 10 Dec 2003 22:46:25 GMT
stderr.log shows that connection is being closed and I wonder if that may be
the cause of problem and how I might get around it?

WARN common.ChannelSocket  - server has closed the current connection (-1)

-----Original Message-----
From: Januski, Ken [mailto:kjanuski@phillynews.com]
Sent: Wednesday, December 10, 2003 4:43 PM
To: Tomcat Users List
Subject: RE: IIS redirector works first time then fails


Just to confirm that I'm not hallucinating I checked to make sure that
uriworkermap.properties said "/examples/*=ajp13". Then I restarted both
Tomcat and IIS. The HelloWorldExample in servlets worked. So I hit refresh.
Same problem: Page cannot be found.


-----Original Message-----
From: Januski, Ken [mailto:kjanuski@phillynews.com]
Sent: Wednesday, December 10, 2003 4:27 PM
To: Tomcat Users List
Subject: IIS redirector works first time then fails


Hi,

This error originally started on ArcIMS 4.01 with Tomcat 4.112 and IIS 5.0.
But I now realize that it affects all servlets not just those used with
ArcIMS. Though all attempts to myServer:8080 work fine attempts to myServer
work once at most. After that they give a 404 error. So the example files
that come with Tomcat work fine at :8080 but just once at most at default of
:80.

This is on a server that used to work fine. I recently moved to a new
department on new floor and brought pc with me. I'm not sure if it's the
move itself that caused the problems or if some experimentation with getting
cgi to work with Tomcat might have inadvertently caused it.

Can anyone hazard a guess as to why the redirector might work successfully
for first access of a site and fail with all others??

Thanks for any help. This is driving me nuts.

Ken Januski



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message