tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Januski, Ken" <kjanu...@phillynews.com>
Subject RE: Can Tomcat really run cgi scripts?
Date Tue, 02 Dec 2003 18:00:41 GMT
Thanks Chris,

I've tried "!#c:\perl\bin\perl.exe", "#!c:\perl\bin", "#!perl", and
"#!/usr/bin/perl" and get same error on each. I've also added perl to the
path environmental PATH variable. I do think that you're right about missing
PATH information so I'll keep experimenting. I just can't figure out what
additional paths to try.

Ken

-----Original Message-----
From: Christopher Schultz [mailto:christopher.d.schultz@comcast.net]
Sent: Tuesday, December 02, 2003 12:53 PM
To: Tomcat Users List
Subject: Re: Can Tomcat really run cgi scripts?


Ken,

 > But now I'm stuck with this error:
> java.io.IOException: CreateProcess: perl
> C:\Tomcat4112\webapps\examples\WEB-INF\cgi\exp.cgi

This is likely to be due to the lack of PATH information available to 
the script itself. Try using #!/usr/bin/perl in your script instead of 
#!perl

I've heard some complains about sub-process permissions, but my initial 
reaction is that they are errant complaints.

-chris


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message