tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shapira, Yoav" <Yoav.Shap...@mpi.com>
Subject RE: load-on-startup and multiple coyotes
Date Tue, 02 Dec 2003 17:17:43 GMT

Howdy,

>As soon as I start using 2 coyote connectors together with <load-on-
>startup>
>tomcat initializes the database pools twice.
>Interestingly it keeps initializing things twice even if I add a third
>coyote.

You have one load-on-startup tag for each servlet element in web.xml,
and one servlet element in web.xml for each servlet class, even when you
have multiple connectors in server.xml, right?

Tomcat (4.x) will create an instance of your servlet for every <servlet>
tag in web.xml.   Each instance will be initialized, so that may be what
you're seeing.

Yoav Shapira




This e-mail, including any attachments, is a confidential business communication, and may
contain information that is confidential, proprietary and/or privileged.  This e-mail is intended
only for the individual(s) to whom it is addressed, and may not be saved, copied, printed,
disclosed or used by anyone else.  If you are not the(an) intended recipient, please immediately
delete this e-mail from your computer system and notify the sender.  Thank you.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message