tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nikola Milutinovic <Nikola.Milutino...@ev.co.yu>
Subject Re: DOES_ANYONE_HAVE_CONFIGURED_MOD_JK2+APACHE+TOMCAT_USING_unix_channel
Date Wed, 31 Dec 2003 06:38:22 GMT
Ingmars Rubenis wrote:
> Hello All!
> 
> I am using standart Red Hat 9.0 apache http server 2.40
> Tomcat 4.2.24
> Mod_jk2... .rpm

RedHat 9.0 - ugh!

> I have not tried to install it from source.

Do try.

> I have tried all kind of mod_jk2 rpms, but still I get error:
> INFO: APR not loaded, disabling jni components: java.io.IOException:
> /usr/lib/httpd/modules/jkjni.so: /usr/lib/httpd/modules/jkjni.so: undefined
> symbol: apr_md5_final

Looks like jkjni.so (or should I say, dynamic loader) cannot load "libapr.so". 
Checkout your dynamic library settings. It could also be in "libaprutil.so", not 
sure.

> Does anybody have installed mod_jk2 rpm successfully as connector using unix
> socket, please write back to list.

I've built mod_jk2 v2.0.2 from source on Mandrake 9.1 with Apache 2.0.48 and 
Tomcat 4.1.24. I'm using UNIX socket. Search the archives, I've posted my config 
files two or three weeks ago. There are a couple of gotcha-s.

Nix.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message