tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Jesso" <jje...@global-matrix.com>
Subject ssl startup problem
Date Tue, 16 Dec 2003 20:17:15 GMT
I am using AIX5.2, Tomcat 4.1.24, Java 1.4.

When I start Tomcat using SSL I get errors in the catalina.out.



The security providers in the java.security file are listed as follows:

security.provider.1=com.ibm.jsse.IBMJSSEProvider
security.provider.2=com.ibm.crypto.provider.IBMJCE
security.provider.3=com.ibm.security.jgss.IBMJGSSProvider
security.provider.4=com.ibm.security.cert.IBMCertPath



The catalina.out is:

Dec 16, 2003 2:04:20 PM org.apache.commons.modeler.Registry loadRegistry
INFO: Loading registry information
Dec 16, 2003 2:04:20 PM org.apache.commons.modeler.Registry getRegistry
INFO: Creating new Registry instance
Dec 16, 2003 2:04:24 PM org.apache.commons.modeler.Registry getServer
INFO: Creating MBeanServer
Dec 16, 2003 2:04:27 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on port 80
Exception during startup processing
java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at 
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:61)
        at 
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:40)
        at java.lang.reflect.Method.invoke(Method.java:335)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:203)
Caused by: java.lang.NoClassDefFoundError: 
com/sun/net/ssl/internal/ssl/Provider
        at 
org.apache.tomcat.util.net.jsse.JSSEImplementation.getServerSocketFactory(JSSEImplementation.java:90)
        at 
org.apache.coyote.http11.Http11Protocol.checkSocketFactory(Http11Protocol.java:458)
        at 
org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java:133)
        at 
org.apache.coyote.tomcat4.CoyoteConnector.initialize(CoyoteConnector.java:1117)
        at 
org.apache.catalina.core.StandardService.initialize(StandardService.java:579)
        at 
org.apache.catalina.core.StandardServer.initialize(StandardServer.java:2246)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:511)
        at org.apache.catalina.startup.Catalina.execute(Catalina.java:400)
        at org.apache.catalina.startup.Catalina.process(Catalina.java:180)
        ... 5 more


What could be the problem?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message