tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philipp Taprogge <Philipp.Tapro...@gmx.net>
Subject VERY weird problem with commons-logging and Tomcat5
Date Thu, 11 Dec 2003 20:43:07 GMT
Hi!

I have a very disgusting problem here... I am developing a webapp 
which uses commons-logging and log4j.
All I do is use the commons' Log and LogFactory in my application and 
place a log4j.properties file in my WEB-INF/classes.
This property file looks like this (w/out the CR in the middle line of 
course):

log4j.rootCategory=DEBUG, warthoglog
log4j.appender.warthoglog=org.apache.log4j.RollingFileAppender
log4j.appender.warthoglog.layout=org.apache.log4j.PatternLayout
log4j.appender.warthoglog.layout.ConversionPattern=%d{ISO8601}
	[%-15C{1}] %-5p - %m%n
log4j.appender.warthoglog.File=${catalina.home}/logs/warthog.log
log4j.appender.warthoglog.MaxFileSize=2048KB
log4j.appender.warthoglog.MaxBackupIndex=20
log4j.appender.warthoglog.Append=true

This works fine, except that I get not only my application's log 
messages but _ALL_ tomcat debug logging in this file, which firstly 
slows down my machine (no wonder) and secondly grows the logfile to a 
few MBs just from startup.
What the heck am I doing wrong here? This setup worked perfectly in 
the last tomcat4.

Can anyone advice?

	Philipp Taprogge

-- 
"I love deadlines, I love the whooshing noise they make as they go by"
- Douglas Adams


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message