tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Hardy <ahardy.str...@cyberspaceroad.com>
Subject Re: connection refused, localhost not found
Date Tue, 09 Dec 2003 09:26:11 GMT
On 12/08/2003 01:46 PM Damien Pacaud wrote:
> i disagree with you, since the root context works fine....
> he's got a server up and running listenning on port 8080 but his app does
> create an error/interaction with it (hope i got this correct for the
> original email)
> 
> Unfortunately i haven't got a clue what is wrong....Does your app handle
> some network code that could cause it to crash when loaded via te url :
> http://localhost:8080/myapp/ ?
> 


Hi guys, Damien,
you are right - it was network code - well, a network module to handle 
redirects to & from SSL. I had simply forgotten to reconfigure the ports 
after I configured it for the first time for the production machine! Mea 
culpa. The module was inadvertently redirecting requests from 8080 to 
80, which of course was then refused.

I only realised this once I started using wget to have a look at the 
responses in detail.

Thanks for the help.

Adam

> ----- Original Message ----- 
> From: "Patrick Ale" <Patrick.ale@hq.freeler.nl>
> To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
> Sent: Monday, December 08, 2003 1:41 PM
> Subject: RE: connection refused, localhost not found
> 
> 
> Well,
> 
> I got this problem with MLDonkey (not really java, I know but hey.. :P)
> 
> This simply means your program crashes on startup and that nothing listens
> on port 8080.
> 
> Now.. dunno what browser you use but I had this with Mozilla.
> I tried to connect to http://localhost:4080/ it didnt find anything on that
> port so it
> went on with resolving random/known by mozilla things, till it found
> localhost.net.au which
> actually is an existing page.
> 
> Motto of this story is: your app is not running or not on port 8080 :-)
> 
> Patrick Ale
> System administrator Freeler B.V
> 
> "Muda o mundo, começe com você mesmo"
> 
> 
> 
>>-----Oorspronkelijk bericht-----
>>Van: Adam Hardy [mailto:ahardy.struts@cyberspaceroad.com]
>>Verzonden: maandag 8 december 2003 13:29
>>Aan: Tomcat Users List
>>Onderwerp: connection refused, localhost not found
>>
>>
>>Hi Listers
>>I'm sceptical whether anybody else has ever suffered this bizarre
>>problem so I'm not expecting anybody to be able to help, but this is
>>seriously damaging my enjoyment of Monday morning.
>>
>>I have tomcat 5.0.14 set up on one computer and it works fine mostly,
>>i.e. root context, JSP examples, manager apps are working fine.
>>
>>The problem is with the app I'm developing. On Friday night
>>last week I
>>did loads of debugging to sort out the JNDI connection pool, e.g.
>>configuring the app context, the web.xml etc.
>>
>>Now when I try to call up http://localhost:8080/myapp/ the
>>browser zooms
>>off to find http://www.localhost.net.au! When I try
>>http://127.0.0.1:8080/myapp/ I get a 'connection refused' pop-up from
>>the browsers - on my machine and on others. (root context
>>still works as
>>I said).
>>
>>Obviously I tried restarting tomcat, redeploying the app,
>>taking out all
>>the filters, changing the context name, checked server.xml.
>>
>>Anybody care to take a wild guess about what I need to do?


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message