tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Hardy <ahardy.str...@cyberspaceroad.com>
Subject Re: connection refused, localhost not found
Date Mon, 08 Dec 2003 13:16:09 GMT
The app is not running, yup, guess I can't argue with that. 
Unfortunately it's not logging any exceptions. I see that tomcat starts 
a session for the context, and it logs the request in 
localhost_access_log, but otherwise, it's dead as a dodo.

It's definitely on 8080 - the other contexts are obviously on 8080 and 
still run fine.

On 12/08/2003 01:41 PM Patrick Ale wrote:
> Well, 
> 
> I got this problem with MLDonkey (not really java, I know but hey.. :P)
> 
> This simply means your program crashes on startup and that nothing listens on port 8080.
> 
> Now.. dunno what browser you use but I had this with Mozilla.
> I tried to connect to http://localhost:4080/ it didnt find anything on that port so it
> went on with resolving random/known by mozilla things, till it found localhost.net.au
which
> actually is an existing page.
> 
> Motto of this story is: your app is not running or not on port 8080 :-)
> 
> Patrick Ale
> System administrator Freeler B.V
> 
> "Muda o mundo, começe com você mesmo"
>  
> 
> 
>>-----Oorspronkelijk bericht-----
>>Van: Adam Hardy [mailto:ahardy.struts@cyberspaceroad.com]
>>Verzonden: maandag 8 december 2003 13:29
>>Aan: Tomcat Users List
>>Onderwerp: connection refused, localhost not found
>>
>>
>>Hi Listers
>>I'm sceptical whether anybody else has ever suffered this bizarre 
>>problem so I'm not expecting anybody to be able to help, but this is 
>>seriously damaging my enjoyment of Monday morning.
>>
>>I have tomcat 5.0.14 set up on one computer and it works fine mostly, 
>>i.e. root context, JSP examples, manager apps are working fine.
>>
>>The problem is with the app I'm developing. On Friday night 
>>last week I 
>>did loads of debugging to sort out the JNDI connection pool, e.g. 
>>configuring the app context, the web.xml etc.
>>
>>Now when I try to call up http://localhost:8080/myapp/ the 
>>browser zooms 
>>off to find http://www.localhost.net.au! When I try 
>>http://127.0.0.1:8080/myapp/ I get a 'connection refused' pop-up from 
>>the browsers - on my machine and on others. (root context 
>>still works as 
>>I said).
>>
>>Obviously I tried restarting tomcat, redeploying the app, 
>>taking out all 
>>the filters, changing the context name, checked server.xml.
>>
>>Anybody care to take a wild guess about what I need to do?


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message