tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cord Awtry" <kip...@rcn.com>
Subject RE: Tomcat 4.1.18 MailSession Problem
Date Wed, 24 Dec 2003 05:10:25 GMT
Yoav,

        <Resource name="mail/MyMail" auth="Container
type="javax.mail.Session" />
        <ResourceParams name="mail/MyMail">
          <parameter>
            <name>mail.smtp.host</name>
            <value>smtp.rcn.com</value>
          </parameter>
          <parameter>
            <name>mail.transport.protocol</name>
            <value>smtp</value>
          </parameter>
        </ResourceParams>	

	Thanks,

		-C-

-----Original Message-----
From: Shapira, Yoav [mailto:Yoav.Shapira@mpi.com] 
Sent: Monday, December 22, 2003 9:33 AM
To: Tomcat Users List
Subject: RE: Tomcat 4.1.18 MailSession Problem


Howdy,
What's your Resource tag in server.xml for mail/MyMail look like?

Yoav Shapira
Millennium ChemInformatics


>-----Original Message-----
>From: Cord Awtry [mailto:kipsta@rcn.com]
>Sent: Sunday, December 21, 2003 9:24 PM
>To: tomcat-user@jakarta.apache.org
>Subject: Tomcat 4.1.18 MailSession Problem
>
>Hello all,
>
>            I'm hoping someone can given me some help here. I'm
>attempting to set up a mail session but I can't seem to get Tomcat to
>use the specified host of the mail server, it keeps using only
>localhost.
>
>            In my web.xml, I have:
>
>  <resource-ref>
>    <description>My Mail Server</description>
>    <res-ref-name>mail/MyMail</res-ref-name>
>    <res-type>javax.mail.Session</res-type>
>    <res-auth>Container</res-auth>
>  </resource-ref>
>
>            And in the server.xml, I have:
>
>  <ResourceParams name="mail/MyMail">
>    <parameter>
>      <name>mail.smtp.host</name>
>      <value>smtp.myserver.com</value>
>    </parameter>
>  </ResourceParams>
>
>            No matter what I do I get error from the mail server that
it
>can't relay my message. When I debug this and look at the session, the
>mail.smtp.host is set to localhost.
>
>            Any idea on what I've done wrong?
>
>            Thanks in advance for any help,
>
>                        -C-



This e-mail, including any attachments, is a confidential business
communication, and may contain information that is confidential,
proprietary and/or privileged.  This e-mail is intended only for the
individual(s) to whom it is addressed, and may not be saved, copied,
printed, disclosed or used by anyone else.  If you are not the(an)
intended recipient, please immediately delete this e-mail from your
computer system and notify the sender.  Thank you.



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message