tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phupha Punyapotasakul" <phu...@thaiwebbusiness.com>
Subject Jikes with -encoding option supported
Date Sun, 07 Dec 2003 04:56:16 GMT
Hi,


Refer to Tomcat documentation.


If you wish to use Jikes to compile JSP pages:

- Download and install jikes. jikes must support the -encoding option.
Execute jikes -help to verify that it was built with support for -encoding.
- Set the init parameter compiler to jikes.
- Define the property -Dbuild.compiler.emacs=true when starting Tomcat by
adding it to your CATALINA_OPTS environment variable. This changes how jikes
outputs error messages so that it is compatible with Jasper.
- If you get an error reporting that jikes can't use UTF8 encoding, try
setting the init parameter javaEncoding to ISO-8859-1.



Unfortunately, lastest Jikes binary release seem not support -encoding
option. So, I need helps. Does anyone know where to download Jikes binary
release both for Linux and Win32 which support -encoding option?


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message