tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kilic, Hakan" <Hakan.Ki...@scansoft.com>
Subject RE: request.getremoteAddr() returning 127.0.0.1 (localhost)
Date Fri, 28 Nov 2003 23:27:10 GMT
It didn't attach the file. Here it is below:

<Server port="8005" shutdown="SHUTDOWN" debug="0">

  <Service name="Tomcat-Standalone">
         
    <Connector className="org.apache.catalina.connector.http.HttpConnector"
               port="7777" minProcessors="64" maxProcessors="256"
               enableLookups="false" redirectPort="8443"
               acceptCount="64" debug="0" connectionTimeout="60000"/>

   <!-- Define a SSL Coyote HTTP/1.1 Connector on port 8443 -->
    <!--
    <Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
               port="8443" minProcessors="64" maxProcessors="256"
               enableLookups="false"
	       acceptCount="100" debug="0" scheme="https" secure="true"
               useURIValidationHack="false" disableUploadTimeout="true">
      <Factory
className="org.apache.coyote.tomcat4.CoyoteServerSocketFactory"
               clientAuth="false" protocol="TLS" />
    </Connector>
    -->

    <Engine name="Standalone" defaultHost="localhost" debug="0">

      <!-- Global logger unless overridden at lower levels -->
      <Logger className="org.apache.catalina.logger.FileLogger"
              prefix="catalina_log." suffix=".txt"
              timestamp="true"/>

      <!-- Because this Realm is here, an instance will be shared globally
-->

      <Realm className="org.apache.catalina.realm.MemoryRealm" />

      <!-- Define the default virtual host -->
      <Host name="localhost" debug="0" appBase="webapps" 
       unpackWARs="true" autoDeploy="true">

        <Valve className="org.apache.catalina.valves.AccessLogValve"
                 directory="logs" prefix="localhost_access_log."
suffix=".txt"
                 resolveHosts="false" pattern="common"/>

        <Logger className="org.apache.catalina.logger.FileLogger"
                 directory="logs"  prefix="localhost_log." suffix=".txt"
	        timestamp="true"/>

        <!-- Root context -->
        <!-- <Context path="" docBase="ROOT" debug="0"/> -->

      </Host>
    </Engine>
  </Service>
</Server>


-----Original Message-----
From: Kilic, Hakan [mailto:Hakan.Kilic@scansoft.com]
Sent: Friday, November 28, 2003 6:07 PM
To: 'Tomcat Users List'
Subject: request.getremoteAddr() returning 127.0.0.1 (localhost)


Hi all,

I've searched the email archive and bugzilla, and come across bug 20041:

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20041 back from June 2003.

I'm using Tomcat 4.1.24 Standalone, and I've attached the server.xml file
I'm using (I'm using the Catalina connector).

Does anyone know what the problem is and if there is a workaround to this? 

Thanks!

-Hakan



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message