tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Sierra Fernandez <>
Subject RE: Tomcat cannot fine java classes
Date Mon, 24 Nov 2003 08:06:20 GMT

Perhaps it is a bit obvious but I can help in other way...have you deployed
correctly the app? I you have the web.xml file and the servlets
declared in it? Sorry if you do...i can help more :-(

David Sierra Fernandez
e-mail: <>

> -----Mensaje original-----
> De: news []En nombre de Werner Daum
> Enviado el: domingo, 23 de noviembre de 2003 22:50
> Para:
> Asunto: Tomcat cannot fine java classes
> Hi,
> I have the following problem with tomcat 4.1.27:  my java classes cannot
> be found. When I request a JSP which uses a java class, I get messages
> like this:
> File not found:
> '

In this case the class name is AdminGroupServlet and the corresponding
class file it is located in the directory
however tomcat doesn't seem to resolve the above URL correcotly.

I tried to request example JSPs which came with tomcat (in
webapps/examples), and they worked, howewer I had no success with my own
classes. When I call, I get the following messages:

Using CATALINA_BASE:   /data/htdocs/learnweb/jakarta-tomcat-4.1.27
Using CATALINA_HOME:   /data/htdocs/learnweb/jakarta-tomcat-4.1.27
Using CATALINA_TMPDIR: /data/htdocs/learnweb/jakarta-tomcat-4.1.27/temp
Using JAVA_HOME:       /usr/local/j2sdk1.4.2_02

I tried to add the path to my classes to CLASSPATH in, but
after that I could not use tomcat at all. Any ideas, what I am doing wrong?

Thanks in advance,
Werner Daum

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message