tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: Missing DataSourceRealm MBean definition
Date Thu, 06 Nov 2003 17:05:43 GMT
At 11:09 AM 11/6/2003 -0500, you wrote:
>Jacob,
>>>ps. I also noticed that the 'LE' version does not come with commons-dbcp 
>>>and commons-pool libraries. I thought the 'LE' version was only 
>>>trimmed-down for JDK 1.4 users because it did not include an XML parser 
>>>-- which is included with the JDK, now. What gives?
>>
>>Tomcat5 no longer provides a separate "LE" version.  You can take that as 
>>a hint not to use the "LE" version in Tomcat4.1.x.  It causes nothing but 
>>confusion.
>
>I disagree. The 'LE' version actually has less confusion because there 
>aren't fighting XML parsers involved.
>
>I don't know why Tomcat 5.x doesn't have an 'LE' version. I couldn't find 
>any official word that LE versions "caused confusion and have been 
>elimintated" :)
>
>-chris

Search the archives.  There has been plenty of discussion on this.  The 
docs mention that the LE version leaves out what the JDK already 
has.  However, other stuff such as dbcp and other jars are removed as 
well.  This is not documented well (if at all) and has been, in my 
experience on the list, the cause of endless confusion.  If all you are 
concerned about is the XML stuff, just delete everything in the 
common/endorsed directory and you are good to go.  However, I wouldn't do 
this as crimson isn't exactly up to date, the dom apis aren't standard 
(taken from an unofficial version of the spec), and I would make sure to 
put xalan.jar in there to override the old buggy version that comes with 
the JDK.

Jake


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message