tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nikola Milutinovic <Nikola.Milutino...@ev.co.yu>
Subject Re: Missing DataSourceRealm MBean definition
Date Fri, 07 Nov 2003 06:22:55 GMT
Christopher Schultz wrote:
> Jacob,
> 
>> Tomcat5 no longer provides a separate "LE" version.  You can take that 
>> as a hint not to use the "LE" version in Tomcat4.1.x.  It causes 
>> nothing but confusion.
> 
> I disagree. The 'LE' version actually has less confusion because there 
> aren't fighting XML parsers involved.
> 
> I don't know why Tomcat 5.x doesn't have an 'LE' version. I couldn't 
> find any official word that LE versions "caused confusion and have been 
> elimintated" :)

I would second your point of view IF guys who make LE version gave us pointers 
to ALL missing components, like JavaMail, etc.

On the other hand, using system-wide XML parsers, and only those, has a 
drawback. Suppose one of your applications needs a particular version, while it 
doesn't sit well with Tomcat. What confusion will ensue then?

I believe that Craig commented something like that on the notion of having 
"global" Struts installation in Tomcat. OK, granted, it makes more sense, since 
you can build your WebApp for a particular version of Struts, while XML API 
should stay the same. But still, if you have a combo that is working - Tomcat 
X.Y.Z and Xerces A.B.C - then it is reasonable to ship it together.

Nix.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message