tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rodrigo Ruiz <rr...@gridsystems.com>
Subject Re: Installing jakarta on linux RH9
Date Wed, 05 Nov 2003 09:04:27 GMT
Looking at the Red Hat 9 Release Notes, it seems that only JDKs prior to 
1.4.1 fail. You are using 1.4.2, so you are not supposed to need the 
LD_ASSUME_KERNEL setting ;-)

The problem comes from a new implementation of the POSIX Thread Native 
Library. This new version corrects some deviances from the POSIX 
standard, so applications that rely on these differences will fail.

Regards,
Rodrigo

Christopher Schultz wrote:

> All,
>
>>> The newest version (4.1.29) should be fine.  If I recall, however, 
>>> there
>>> was a problem with Sun's Java Virtual Machine, and RH9, which used an
>>> incompatible threading library.  
>>
>>
>> No, on RH 9, all VMs will actually need the LD_ASSUME_KERNEL env 
>> variable (look in the archives for the details on the problems and 
>> the workaround).
>
>
> Is this accurate? I use RH9 with kernel 2.4.20/i686, JDK 1.4.2-b28 
> without any LD_ASSUME_KERNEL setting (that I know of).
>
> Is this for a specific kernel version or architecture?
>
> -chris
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message