tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nikola Milutinovic" <Nikola.Milutino...@ev.co.yu>
Subject OT: Linux specific JVM problem
Date Thu, 20 Nov 2003 18:15:59 GMT
Hi all.

I have a problem which, I suppose, I can solve - this way or another. I'd like to hear a recomendation
from the list, since I'm supposed to go live ASAP.

I have installed:

- Mandrake Linux 9.1 - paranoid security setting
- Sun JDK 1.4.2 rel_02
- Tomcat 4.1.24 from RPM

If I try to start Tomcat via "/etc/init.d/tomcat4 start" it dies. If I start it manually,
it runs.

I have tracked down the problem to permissions. The "regular way" tries to run Tomcat and
it's underlying JVM as user "tomcat4" and that fails with this message:

[root@External tomcat4]# more catalina.out
#
# HotSpot Virtual Machine Error, Internal Error
# Please report this error at
# http://java.sun.com/cgi-bin/bugreport.cgi
#
# Java VM: Java HotSpot(TM) Server VM (1.4.2_02-b03 mixed mode)
#
# Error ID: 4F533F4C494E55580E43505001C9
#

Heap at VM Abort:
Heap


****************
Another exception has been detected while we were handling last error.
Dumping information about last error:
ERROR REPORT FILE = (N/A)
PC                = 0x46098c28
SIGNAL            = 11
FUNCTION NAME     = (N/A)
OFFSET            = 0xFFFFFFFF
LIBRARY NAME      = (N/A)
Please check ERROR REPORT FILE for further information, if there is any.
Good bye.

If I run "java -version" as user "tomcat4" I get the same. If I run it as "root", it is OK.

Running 'strace -o run-out.log -f su - tomcat4 -c "/usr/bin/dtomcat4 start"' shows that JVM
is trying to access portions of "/proc" file system and fails. I recall, that I've managed
to "solve" the problem by adding user "tomcat4" to "adm" group.

This is the STDOUT of "strace":

/proc/26880/status: Permission denied

And this is from "strace" log:

16313 open("/proc/stat", O_RDONLY)      = -1 EACCES (Permission denied)
16313 open("/proc/cpuinfo", O_RDONLY)   = -1 EACCES (Permission denied)
16313 open("/proc/meminfo", O_RDONLY)   = -1 EACCES (Permission denied)
16313 open("/proc/self/stat", O_RDONLY) = -1 EACCES (Permission denied)

Is that the recomended way to go?

Any advice?

Nix.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message