tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yansheng Lin" <yansheng....@isogis.com>
Subject RE: Enabling <valve> crashed ESRI Arcims applications.
Date Fri, 14 Nov 2003 15:09:36 GMT
Oh once I commented that line, everything worked fine.  I will try "debug='100'"
today to see what kind of error I was getting.

-----Original Message-----
From: Januski, Ken [mailto:kjanuski@phillynews.com] 
Sent: Thursday, November 13, 2003 4:44 PM
To: Tomcat Users List
Subject: RE: Enabling <valve> crashed ESRI Arcims applications.


It might be a good idea to put the comment back in, restart Tomcat, and then
see whether or not you get these errors. At least that way you know whether
or not they're related to your changes.


-----Original Message-----
From: Yansheng Lin [mailto:yansheng.lin@isogis.com]
Sent: Thursday, November 13, 2003 5:59 PM
To: 'Tomcat Users List'
Subject: RE: Enabling <valve> crashed ESRI Arcims applications.


Nope, no errors or exception(not that I know of:). I did a 

>tail apache_log.2003-11-13.txt

and the log just stop there after the first arcims request.  And on the
arcims
server side, nothing happens, i.e., no arcims request was received.  I do
get
the following exception when I started my tomcat.  But I think that
exception is
always there, with or without <Valve>.

--------------
2003-11-13 15:20:14 [org.apache.catalina.connector.warp.WarpConnection]
Exception on socket
java.net.SocketException: Socket closed
        at java.net.SocketInputStream.socketRead0(Native Method)
        at java.net.SocketInputStream.read(SocketInputStream.java:116)
        at java.net.SocketInputStream.read(SocketInputStream.java:144)
        at org.apache.catalina.connector.warp.WarpConnection.recv(Unknown
Source)
        at
org.apache.catalina.connector.warp.WarpRequestHandler.handle(Unknown
Source)
        at org.apache.catalina.connector.warp.WarpConnection.run(Unknown
Source)
        at java.lang.Thread.run(Thread.java:536)




-----Original Message-----
From: Filip Hanik [mailto:devlists@hanik.com] 
Sent: Thursday, November 13, 2003 3:46 PM
To: Tomcat Users List
Subject: Re: Enabling <valve> crashed ESRI Arcims applications.


did you get a stack trace?

Filip
----- Original Message -----
From: "Yansheng Lin" <yansheng.lin@isogis.com>
To: "'Tomcat Users List'" <tomcat-user@jakarta.apache.org>
Sent: Thursday, November 13, 2003 2:41 PM
Subject: Enabling <valve> crashed ESRI Arcims applications.



Wow, this is kind of cool.  And I couldn't explain it!

If I uncomment the following header logging in my server.xml, all of
'arcims-related' application does not work anymore.  And it seems that the
request wasn't even sent to 'arcims' server.

<Valve className="org.apache.catalina.valves.RequestDumperValve"/>

Unfortunately, arcims uses a propriety servlet.  So I have no idea what's
inside
of that class.

All other application worked with logging.

Thanks!


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message