tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Kennedy" <j...@gigaheads.com>
Subject Datasource problem upgrading from 4.06
Date Wed, 26 Nov 2003 17:30:06 GMT
Below is a little bit of the trace I'm seeing.


org.apache.commons.dbcp.SQLNestedException: Cannot create JDBC driver of class 'com.
microsoft.jdbc.sqlserver.SQLServerDriver' for connect URL 'null', cause:
java.lang.NullPointerException
        at java.lang.String.regionMatches(String.java:967)
        at com.microsoft.jdbc.base.BaseURLParser.parse(Unknown Source)
        at com.microsoft.jdbc.base.BaseDriver.acceptsURL(Unknown Source)
        at java.sql.DriverManager.getDriver(DriverManager.java:232)
        at org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.
java:743)
        at org.apache.commons.dbcp.BasicDataSource.getConnection(BasicDataSource.jav
a:518)
.....


I just upgraded from Tomcat 4.06 to 4.1.29.  I've made no changes to code or web.xml.  Just
a straight copy of my app over to the new server.  Here's a snippet of my server.xml.  The
below config for the context is the same (which worked on 4.06).  I'm having problems with
the jdbc/eaglepro datasource.

<Context path="/cds" docBase="D:\serverapps\Tomcat 4.1\webapps-noauto\cds" reloadable="true"
debug="0" crossContext="true">
    <Logger className="org.apache.catalina.logger.FileLogger" prefix="localhost_cds_log."
suffix=".log" timestamp="true"/>
    <Environment name="maxExemptions" type="java.lang.Integer" value="15"/>
    <Parameter name="context.param.name" value="context.param.value" override="false"/>
    <Resource name="jdbc/eaglepro" auth="SERVLET" type="javax.sql.DataSource"/>
    <ResourceParams name="jdbc/eaglepro">
        <parameter><name>user</name>
            <value>eflowuser_t</value>
        </parameter>
        <parameter><name>password</name>
            <value>#$%^&*</value>
        </parameter>
        <parameter><name>driverClassName</name>
            <value>com.microsoft.jdbc.sqlserver.SQLServerDriver</value>
        </parameter>
        <parameter><name>driverName</name>
               <value>jdbc:microsoft:sqlserver://192.168.2.14:1433;DatabaseName=jtest;SelectMethod=cursor</value>
        </parameter>
    </ResourceParams>

    <Resource name="mail/bay4" auth="Container" type="javax.mail.Session"/> 
    <ResourceParams name="mail/bay4"> 
        <parameter> <name>mail.smtp.host</name> 
        <value>smtp.algx.net</value> 
        </parameter> 
        </ResourceParams> 

<Realm className="org.apache.catalina.realm.JDBCRealm" debug="99"
driverName="com.microsoft.jdbc.sqlserver.SQLServerDriver"
connectionURL="jdbc:microsoft:sqlserver://192.168.2.14:1433;DatabaseName=eflow_dev;User=eflowadmin;Password=#$%^&*;SelectMethod=cursor"
userTable="ef_users" userNameCol="user_name" userCredCol="user_password"
userRoleTable="j2ee_user_roles" roleNameCol="role_name"/>

</Context>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message