tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilpin, Michael R." <Michael.Gil...@Honeywell-TSI.com>
Subject Tomcat 4.0, server.xml and SSL
Date Wed, 29 Oct 2003 18:50:14 GMT

I installed SSL on my Apache Tomcat 4.0 server.  When the SSL Connector portion of server.xml
is commented-out, my Apache Tomcat server service restarts with no problems.  But when the
SSL Connector portion is not commented-out, the Apache Tomcat server
service will NOT restart.  It doesn't matter whether I'm trying to restart it as a Windows
service or straight from startup.bat.  It just won't restart.  

Here's a snippet of server.xlm:

  <!-- Define an SSL HTTP/1.1 Connector on port 8443 -->
     
      <Connector className="org.apache.catalina.connector.http.HttpConnector"
               port="443" minProcessors="5" maxProcessors="75"
               enableLookups="true"
	       acceptCount="10" debug="0" scheme="https" secure="true">
      <Factory className="org.apache.catalina.net.SSLServerSocketFactory"
               clientAuth="false" protocol="TLS"  
		keystoreFile="c:\honey\honeywelltsi"
		keystorePass="password"/>

    </Connector> 


I imported a Root Certificate and Server Certificate from the Register.com certificate authority.
  The import process appeared to be clean and successful.  

Any ideas folks?




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message