tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Hardy <ahardy.str...@cyberspaceroad.com>
Subject Re: Mozilla, SSL certificates, and Tomcat 5
Date Wed, 22 Oct 2003 16:03:04 GMT


Jeff,
I get strange behaviour with Moz & tomcat5 SSL but not what you're 
describing. To do with the form-based authentication.

Adam

On 10/22/2003 05:58 PM Jeff Jackson wrote:
> I'm using Sun's j2sdk1.4.2.  Are you saying that using IBM's JVM would 
> make a difference?
> 
> I've read the howto.  Again, I have SSL working with IE6.  Mozilla 1.4 
> on the same machine gets a server certificate, but then fails to get any 
> data.  Seems like a handshake problem to me.
> 
> 
> Bill Barker wrote:
> 
>> Are you using IBM's JVM?  If so, please see the latest SSL-howto
>> documentation for how to get SSL working.
>>
>> "Jeff Jackson" <jackson@mathcs.duq.edu> wrote in message
>> news:Pine.LNX.4.44.0310211504280.2840-100000@defelice.mathcs.duq.edu...
>>
>>> Short version: I can access Tomcat via SSL from IE6, but not from 
>>> Mozilla
>>> 1.4/Netscape 7.1.  Is this a known problem, and if so, what's the
>>> work-around?
>>>
>>> Long version:
>>>
>>> I've installed Sun's Java Web Services Developer Pack 1.3 version of
>>> Tomcat 5 under Linux.  I also created a self-signed certificate using 
>>> the
>>> Java keytool, accepting the default keystore location and using the
>>> default "changeit" password.  When I enable SSL (either by removing
>>> comment delimiters from the SSL Connector in the out-of-the-box
>>> server.xml, or by running the web-based admin tool) and restart Tomcat,
>>> there are no error messages in any log files.  And I can access the SSL
>>> port with an https URL using IE6 from a Windows client.
>>>
>>> But Mozilla 1.4 and Netscape 7.1 (on the same Windows client I used for
>>> IE) both give a "The document contains no data." alert when I try to
>>> access the same URL, after a several second delay and a number of
>>> "Connecting"/"Connected" status messages.  These browsers have had no
>>> trouble accessing other https URL's, so I'm assuming that it's a Tomcat
>>> issue.
>>>
>>> I have tried changing the server.xml Host name from localhost to my 
>>> actual
>>> host name and changing the Factory protocol from TLS to SSL (based on
>>> something I saw in another SSL question).  This had no apparent effect.
>>>
>>> I also tried using a trial Verisign-signed certificate, with the same
>>> results: IE6 can access the site, Mozilla cannot.
>>>
>>> What am I missing?


-- 
struts 1.1 + tomcat 5.0.12 + java 1.4.2
Linux 2.4.20 RH9


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message