tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Hardy <ahardy.str...@cyberspaceroad.com>
Subject TC5 ssl form-based authentication & mozilla
Date Tue, 14 Oct 2003 16:48:50 GMT
I have set this up with the minimum configuration possible to try to 
find the problem. 1 JSP, one Struts action mapping, 1 servlet mapping, 
and the tomcat realm - no SSO, no filters, no templates, no SSL-redirection.

With this security:

     <web-resource-collection>
       <web-resource-name>SSL 4 Login</web-resource-name>
       <url-pattern>/login.do</url-pattern>
     </web-resource-collection>
     <auth-constraint>
       <role-name>user</role-name>
       <role-name>admin</role-name>
     </auth-constraint>
     <user-data-constraint>
       <transport-guarantee>CONFIDENTIAL</transport-guarantee>
     </user-data-constraint>

when I try to login to my login.do mapping, in mozilla I get repeated 
login requests from tomcat. The first time twice only, the 2nd time 5 
times, 3rd time 10 times etc etc.

I can see from my logging that the realm login is successful, but tomcat 
keeps giving the login page as stated.

This does not happen in IE6 or lynx, in which the login works as normal.

Has anybody else experienced this?

Thanks
Adam

-- 
struts 1.1 + tomcat 5.0.12 + java 1.4.2
Linux 2.4.20 RH9


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message