tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Funk <funk...@joedog.org>
Subject Re: Could Not Start The Tomcat Server After Commenting Out Realm in the server.xml For Using JDBCRealm
Date Thu, 09 Oct 2003 00:19:06 GMT
1) For simplicity, did you coment out the UserDatabaseRealm when placing your 
JDBCRealm at the same level?

2) Make sure the & are encoded as &amp; Otherwise - you xml document is not 
valid.

-Tim

Caroline Jen wrote:

> I encountered this problem:
> 
> I followed the instructions on using the JDBCRealm
> (http://jakarta.apache.org/tomcat/tomcat-4.1-doc/realm-howto.html).
>  I prepared userTable and userRoleTable tables. 
> However, I could not start the Tomcat server after I
> inserted
> 
> [CODE]
> <Realm className="org.apache.catalina.realm.JDBCRealm"
> debug="99"
>     driverName="com.mysql.jdbc.Driver"
>    
> connectionURL="jdbc:mysql://localhost:3306/artimus?user=javauser&password=javadude"
>     userTable="members" userNameCol="user_name"
> userCredCol="user_password"
>     userRoleTable="user_roles"
> roleNameCol="user_role"/>
> [/CODE]
> 
> within the <Engine> tag in the
> $CATALINA_HOME/conf/server.xml file.  
> 
> I first inserted the aforementioned Realm within the
> <context> tag in the $CATALINA_HOME/conf/server.xml
> and I was unable to start the Tomcat server.  I then
> moved the Realm inside the <Engine> tag, but it did
> not help.
> 
> By the way, do you think the user and password given
> in the JDBCRealm are correct?  I configured database
> username and password for use by Tomcat in the
> $CATALINA_HOME/conf/server.xml in the following way
> and I have used this database many times without
> problem.
>  


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message