tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "mtorgler" <mtorg...@torgler.net>
Subject Debug Help with Apache & Tomcat, on WinXP
Date Fri, 31 Oct 2003 12:44:09 GMT
Hey All

I have both Apache 2.047 and Tomcat 4.1.27 configured on my XP machine as a 
localhost service using jk2 configs.  

I followed the directions on the following page:
http://www.greenfieldresearch.ca/technical/jk2_config.html

The two services work individually, all configs are done, but the two 
servers just don't tie together.

My thought is that there is a problem with the way I put together the shm 
file.  In my error.log, Apache is crapping on the shm.create() call:

[Thu Oct 30 20:17:38 2003] [error] shm.init(): No file

But the file is there, I'm not sure how to make it readable/writable to the 
service if that's the problem.

Any help someone could give would be greatly appreciated, THANKS!

Below here are my configs:

My jk2.properties on Tomcat is a single line:

--------------------------------------------------------

#Shared memory directive
shm.file=c:/Apache/Apache2/logs/jk2.shm 

--------------------------------------------------------

My workers2.properties with Apache looks like the following:

-----------------------------------------------------------------------------
#define the shared memory file
[shm]
  file=c:/Apache/Apache2/logs/jk2.shm
  size=1000000

# Define the communication channel
[channel.socket:localhost:8009]
port=8009
#host=127.0.0.1
tomcatId=localhost:8009
debug=1

[ajp13:localhost:8009]
channel=channel.socket:localhost:8009

# Map the Tomcat examples webapp to the Web server uri space
[uri:/examples/*]
info=C:/Apache/Tomcat/webapps/examples/

[uri:/servlet/*]
info=C:/Apache/Tomcat/webapps/


[status:status]
info=Status worker, displays runtime information
channel=channel.socket:localhost:8009

[uri:/jkstatus/*]
info=Display status information and checks the config file for changes.
group=status:
worker=status:status

[uri:/status/*]
worker=status:localhost:8009
group=status: 
------------------------------------------------------------------------

For reference, I uploaded the bigger docs:
servers.xml:  http://torgler.net/docs/server.xml

workers2.properties: http://torgler.net/docs/workers2.properties

httpd.conf: http://torgler.net/docs/httpd.conf

Also, not sure if these would help or not, the stderr.log outs from the 
Tomcat startup, which looked fine to me

Created catalinaLoader in: C:\Apache\Tomcat\server\lib
Oct 30, 2003 8:17:32 PM org.apache.commons.modeler.Registry loadRegistry
INFO: Loading registry information
Oct 30, 2003 8:17:32 PM org.apache.commons.modeler.Registry getRegistry
INFO: Creating new Registry instance
Oct 30, 2003 8:17:33 PM org.apache.commons.modeler.Registry getServer
INFO: Creating MBeanServer
Oct 30, 2003 8:17:35 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on port 8009
Oct 30, 2003 8:17:39 PM org.apache.struts.util.PropertyMessageResources 
&lt;init&gt;
INFO: Initializing, config='org.apache.struts.util.LocalStrings', 
returnNull=true
Oct 30, 2003 8:17:39 PM org.apache.struts.util.PropertyMessageResources 
&lt;init&gt;
INFO: Initializing, config='org.apache.struts.action.ActionResources', 
returnNull=true
Oct 30, 2003 8:17:40 PM org.apache.struts.util.PropertyMessageResources 
&lt;init&gt;
INFO: Initializing, config='org.apache.webapp.admin.ApplicationResources', 
returnNull=true
Oct 30, 2003 8:17:45 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on port 8009</font></p>
	


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message