tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lawence <allforli...@yahoo.com>
Subject RE: Virtual Host Alias Problem
Date Thu, 09 Oct 2003 21:28:42 GMT
Suppose your domains are: d1,d2; corresponding ips are ip1, ip2.
 
<Host name="d1" debug="0" appBase="webapps"
       unpackWARs="true" autoDeploy="true">
<Alias>ip1</Alias>
......
</Host>
 
<Host name="d2" debug="0" appBase="webapps"
       unpackWARs="true" autoDeploy="true">
<Alias>ip2</Alias>
......
</Host>

 
Please let me if it works.

Srinivasu Gandu <SGandu@SoftwareSpecialists.com> wrote:
Hi Lawence,
Would you provide sample host tag or server.xml. I have similar issue here.
I have 2 domains have different ip addresses with in the same tomcat to set
up. will appreciate.
Thanks - srini.

-----Original Message-----
From: Lawence [mailto:allforlinux@yahoo.com]
Sent: Tuesday, October 07, 2003 11:41 AM
To: Tomcat Users List; wchandler@redesetgrow.com
Subject: RE: Virtual Host Alias Problem


Yes, I just duplicated the host entry and changed the second one from domain
to ip. Now both work fine. There should be a better solution but I am happly
with it.

Wade Chandler wrote:Yeah the ipaddress tag.
Also, you'll notice that you'll
have to create extra Host tags if you use anything other than www. As
the prefix for your domain name. I have yet to figure that one out.
But, am planning on looking at the Alias source code. Has anyone else
had this type of a problem with Alias? Lawence you may need to make
another host tag for this. This is the type of issue I have been
having. I have a domain wade.internal.net and rh1.internal.net and
these have to be setup as separate Host names to work. You may
experience this with your ip addresses as well. Also, if you are using
a different ip address and port other than than the standard one you
will need to make sure you have your connectors setup correctly for
that. Like 192.168.1.10:80 and 192.168.1.11:80 if on the same box needs
to connectors one for each IP. Since they are the same port.

-----Original Message-----
From: Lawence [mailto:allforlinux@yahoo.com] 
Sent: Monday, October 06, 2003 12:20 PM
To: Tomcat Users List
Subject: Virtual Host Alias Problem


Dear all,

I have a problem setting the name value for the virtual host entry.
Suppose my domain name is my.company.net and the ip is 233.333.333.33.
If I set the virtual host as my domain name, I can not access the
website using the ip. And if I set it as the IP, I can not visit the
website via the domain name. 

I am wondering if there is a way for me to set alias for the virtual
host.

Thanks in advance.


---------------------------------
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org



---------------------------------
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message