tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Μιχαλίδης Κώστας <mihali...@01p.gr>
Subject encoding problem: tomcat requires restart after computer reboot
Date Wed, 01 Oct 2003 11:45:08 GMT
Hi all,

i'm having a strange problem to which i ran out of ideas on how to get it
fixed.
I'm running Tomcat 4.0 as a windows-service on Win2K Server (SP3).

The problem is that JSP pages with foreign content (iso-8859-7 encoding,
Greek) 
are not displayed correctly immediately AFTER the computer has been
restarted.
To fix it all i need to do is to restart the Tomcat service, 
after which everything works as expected, pages display "normal" Greek.
This is problematic after, lets say, a power failure where the
machine reboots and requires operator interaction to restart the Tomcat
service.

I found that during installation of Windows on a fresh machine, under no 
circumstances must one select Greek locale during regional settings setup.
If Greek is selected this cannot be undone and the only whay to make Tomcat
work correctly is to re-install Windows OS on a fresh machine.
Also, if at any point after succesfull installation the locale is changed to

Greek the same problem occurs.
Changing the locale back to English does not fix the problem.

Has anybody seen anything like this?
What can i do to avoid a clean install?

Thanks to all / Costa Mihalidis (Athens, Greece)

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message