tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rudid...@xs4all.nl
Subject Re: JDBC Realm not working with - Please help
Date Thu, 09 Oct 2003 09:59:39 GMT
Hi again,

I'm using version 4.1.27 of tomcat, and my login page is taking forever to
load. I'm not actually getting any error messages.

Thanks again,

Rudi

>
> Hi,
>
> I'm trying to setup my web app to use JDBC Realm. I am using SQL Server
> 2000.
>
> Here is the script to create tables:
>
> CREATE TABLE [dbo].[t_Role] (
> 	[RoleId] [int] IDENTITY (1, 1) NOT NULL ,
> 	[role] [varchar] (12)
> )
>
>
> CREATE TABLE [dbo].[t_Usr] (
> 	[UsrId] [int] IDENTITY (1, 1) NOT NULL ,
> 	[UsrName] [varchar] (10) ,
> 	[Pwd] [varchar] (10)
> )
>
>
> CREATE TABLE [dbo].[t_UsrRole] (
> 	[UsrRoleAdmin] [int] IDENTITY (1, 1) NOT NULL ,
> 	[UsrName] [varchar] (10) ,
> 	[RoleName] [varchar] (10)
> )
>
>
> Below is the only changes I have made to my server.xml file.
>
>
>       <Realm  className="org.apache.catalina.realm.JDBCRealm" debug="99"
>              driverName="com.microsoft.jdbc.sqlserver.SQLServerDriver"
>           connectionURL="jdbc:microsoft:sqlserver://exp468:1433;DatabaseName=Mosaic;user=sa;password=c0mmun1$t;"
>          connectionName="rudi" connectionPassword="rudi"
>               userTable="t_Usr" userNameCol="UsrName" userCredCol="Pwd"
>           userRoleTable="t_UsrRole" roleNameCol="RoleName" />
>
>
> Any assistance would be greatly appreciated.
>
> Cheers,
>
> Rudi
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message