tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: Logging Error in org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler processConnection
Date Fri, 19 Sep 2003 07:36:37 GMT
See http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22701.  It should be
fixed in the CVS code now, but I haven't finished running tests to close the
bug.

"Martin Grüneberg" <martin.grueneberg@active-group.de> wrote in message
news:7D324937875ED5118B1B00B0D0AB5A0D172753@SERVER-001...
Hallo together,

i have mystery errormessage.
The scenario is:
I develop a struts webapplication with eclipse 2.1.1 (WAST Tomcat plugin)
struts uses common-logging and my backend programm uses log4j.
When i start the application in eclipse with the WAST i can test my
application. after a clicking a while and wait a short time (ca. 1 minute)
i often get the following error message when clicking again on any link.

17.09.2003 12:30:43
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler
processConnection
SCHWERWIEGEND: Error reading request, ignored
org.apache.commons.logging.LogConfigurationException:
org.apache.commons.logging.LogConfigurationException:
org.apache.commons.logging.LogConfigurationException: Class
org.apache.commons.logging.impl.Log4JCategoryLog does not implement Log
at
org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.ja
va:532)
at
org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.ja
va:272)
at
org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.ja
va:246)
at org.apache.commons.logging.LogFactory.getLog(LogFactory.java:395)
at
org.apache.tomcat.util.net.jsse.JSSESupport.<init>(JSSESupport.java:87)
at
org.apache.tomcat.util.net.jsse.JSSE14Support.<init>(JSSE14Support.java:99)
at
org.apache.tomcat.util.net.jsse.JSSE14Factory.getSSLSupport(JSSE14Factory.ja
va:84)
at
org.apache.tomcat.util.net.jsse.JSSEImplementation.getSSLSupport(JSSEImpleme
ntation.java:118)
at
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConne
ction(Http11Protocol.java:385)
at
org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:565)
at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.jav
a:619)
at java.lang.Thread.run(Thread.java:534)
Caused by: org.apache.commons.logging.LogConfigurationException:
org.apache.commons.logging.LogConfigurationException: Class
org.apache.commons.logging.impl.Log4JCategoryLog does not implement Log
at
org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryI
mpl.java:416)
at
org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.ja
va:525)
... 11 more
Caused by: org.apache.commons.logging.LogConfigurationException: Class
org.apache.commons.logging.impl.Log4JCategoryLog does not implement Log
at
org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryI
mpl.java:412)
... 12 more

I don't know how I can fix this. I already tried all different Logger
configurations for the commons Logging
in commons-logging.properties.
I hope somebody knows the answer.

Greetings,
Martin Grüneberg




Mime
View raw message