tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From d.trombe...@mbm.it
Subject Re: DBCP Problems after restart : Server connection failure during transaction
Date Fri, 12 Sep 2003 06:40:55 GMT

After asking help to Nikolas (1,5 h after!) I solved the problem too.
The system manager told me that nothing had happened, but changing
the URL for the DB connection from:

jdbc:mysql://localhost/mbm162?autoReconnect=true

into

jdbc:mysql://127.0.0.1/mbm162?autoReconnect=true

everything worked fine.
Today I gonna talk to the admin again...

As Nikolas said, I did a lot of other things too.
This, however, seems to be the crucial step.

Good luck to everybody!

- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
Dott. Diego Trombetta
MBM Italia s.r.l.
Via L. Pellizzo 14/A 35128 Padova, Italy
Phone : + 39 049.899.5711 Fax : + 39 049.899.5722
E-mail : d.trombetta@mbm.it



                                                                                         
                                       
                    Nikolas List                                                         
                                       
                    <Niko.List@gmx       To:     Tomcat Users List <tomcat-user@jakarta.apache.org>
                             
                    .de>                 cc:                                          
                                          
                                         Subject:     Re: DBCP Problems after restart : Server
connection failure during         
                    11/09/2003            transaction                                    
                                       
                    23.38                                                                
                                       
                                                                                         
                                       
                                                                                         
                                       




Me again,
I did luckily "solve" my problem - at least it vanished :-)
Just for the ones who seem to have the same problems I'm trying to describe
what I did:

Am So, 2003-08-31 um 02.28 schrieb Nikolas List:
> After a reboot of the system (patched the kernel) I now get the
> following error message:
>
> java.sql.SQLException: Server connection failure during transaction.
> Attempted reconnect 3 times. Giving up.
>
It seems that there is no connection to the DBCP or the Connector/J as I
expected.
In some newsgroups I found hints (sorry - didn't save the links) that
the problem could be related to name lookup problems.
My guess is - and it's just a guess - that this has been true in my
case. At least we had problems "relaying" mail from this host later the
week, which seemed to have a related reason.

What I did is the following:
I changed the <url>-value to http://[hostname]/[dbname]
It seems to be important to switch of the autoreconnect at least for one
connect.
After that it worked again and I could reactivate the autoreconnect to
yes.

(Remark: I think this have been the "important" steps I did - I did
quite a lot things that night and the following, desperatly trying to
reestablish this webapp, so I might have overseen a crucial action!)

If I am right the deeper reason is a denial of connect to the mysqld
which is not able to lookup the correct hostname mentioned in his
mysql/user-table. But why didn't I find any log entry in mysql.log?
This denial of connect seems to be hidden through the connection pool
autoreconnect-feature (as I described switching this of and connecting
showed the denial of connect.)

Good Luck - and enlighten me, if anybody comes to a deeper insight on
that problem.

Bye,
Niko







Mime
View raw message